Can not join Unturned game server (stuck on loading, "server lost your connection". Not allowing inbound connections?

512 MB Memory / 20 GB Disk / AMS2 - Ubuntu 16.04.1 x64 I have set up a Unturned gameserver which runs at ports 27015, 27016, 27017. The server loads succesfully without any errors. When I try to join the server, I can see in the debug menu that the server didn’t respond in X seconds, it then disconnects me after a 30 second timer.

I have used this tool: to check if my ports are open, they are not. Even though another post confirmed that all ports are opened by default as soon as a service is listening on them. Just in case I allowed the ports on Uncomplicated FireWall (UFW) both UCP and UDP.

I have been trying a lot of things to no avail. Any help would be greatly appreciated


Hi! It’s possible that the game server is listening on the local loopback interface only ( which would make it inaccessible from outside of the Droplet. Running this command should list all processes that are listening on the three ports that you listed and also show what interfaces they are listening on:

sudo netstat -plutn | grep -E "27015|27016|27017"

I couldn’t get it to work, I gave up on it for now. If you get it working please let me know.

I am facing the same problem. According to netstat the ports are being used by the application but it is not in listening mode. I have tried the same build on AWS and it worked. I also assumed that all inbound connections are permitted by default. Any directions?

Hi, the server is not listening on localhost. It is running on the public IPv4 address. Using “netstat -ntulp”, both ports don’t have the “LISTEN” state. I’m assuming that this is why it won’t allow incoming traffic?

p.s. After reading a little further, the server uses the 2 ports after the ones I give, so if I bind the port to “27015”, it will use ports “27016” and “27017”. The first is for the game itself, the second for Steam services.

Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

From setting of network interface

# Control-alias eth0
Iface eth0 inet static

Please try comment out the local IP address setting like.

In the case of Ubuntu 16.04, this solves the problem. The problem is that the listening IP address was an IP address for DigitalOcean Floating IP.

Machine translation may make reading difficult. Excuse me.

I’ve had the same problem, but I haven’t found a solution.

Did you ever get this to work? Can’t figure this out. WHAT A HEADACHE.

This comment has been deleted