Question

Can't enable private networking on existing droplet

I’ve been trying to enable private networking on a Ubuntu 14.0.4 Droplet in SFO1 following the instructions here: https://www.digitalocean.com/community/tutorials/how-to-enable-digitalocean-private-networking-on-existing-droplets, but so far have had no luck. I’ll power off the server and click enable under private networking, and the progress bar will come up, but after it finishes, it still just shows the button to enable private networking. If I power on the server, under private networking it says I have to power it off to enable private networking.

I checked under history and it lists “Enable Private Networking”, but never “Cfg Reset.”

Is there any step I’m missing here?

Thanks

Show comments

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

So it looks like private networking is actually turned on, but it just doesn’t seem to update in the settings page. The workaround I found is to go to the console access page, and at the bottom, for me at least, the private IP was listed, and it seems to be correct.

Just solved the problem, somewhat at least. While private networking still didn’t show up as enabled under settings, when I went to Console Access, the private IP and related info was all listed, and I was able to use that to finish setting up private networking. I’ve tested it and can ping the private IP from another droplet in the same region, so it definitely works. No clue still why it’s not showing up in settings though.