Question

Can't reach drone server after Step 4 (Drone installation)

Posted May 24, 2021 89 views
GitDockerCI/CDUbuntu 20.04

Hi

I’m a first-timer using Digital Ocean.
I want to set up a Drone continuous integration system to work with Github.

I have followed the How To Install and Configure Drone on Ubuntu 20.04 and all the “nested” tutorials for setting up a droplet, buying a domain, connecting it to digital ocean, etc.
To my knowledge, the steps were successfully completed and domain.com and drone.domain.com both behave as they should in the DNS Lookup Tool.

At the end of Step 4 in the tutorial, I open drone.domain.com, which as expected shows me a page where I need to authorize Drone- Github access. The screen looks like the “Drone UI” section of this article.

Once authorized, Drone is supposed to build a list of repositories.
However, once I press “Authorize ” it quickly flashes with the tab title “Drone | Continuous Integration …”, but then go to the “Site can’t be reached” page.

I can access domain.com. I’m using HostGator as a provider, so right now it only shows me the “Log in to HostGator” button, but it works.

In case it helps, I have previously tried to install Drone locally using docker-compose. Here I saw the exact same behavior, where the localhost port where Drone should be at said “Site can’t be reached”.

I have tried using Firefox and Chrome.

Any help is appreciated.

Submit an answer

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!