Question

Can't setup DNS in Google Domains

I’ve acquired a domain (fecho.app) in Google Domains and I’ve been trying to link it with a Wordpress project that is running in a Digital Ocean droplet. However, when I access my domain I get the following error: ERR_CONNECTION_REFUSED. Before that, I was able to access my webpage through the IP address.

In order to apply the domain I did the following:

  • In Google Domains I chose “Use the Google Domains name servers”
  • Still on the same page, I added two records in the “Custom resource records” section
Name Type Data
@ A <ip-address>
www CNAME fecho.app

With that, I waited 48 hours as recommended by Google with no avail. The IP address redirects to fecho.app which returns connection refused, nslookup command returns the right IP address, I’ve also checked propagation in dnschecker.org, and the firewall doesn’t seem to be the problem. I’m out of ideas to solve this issue… so any help is really appreciated.

Subscribe
Share

One side note that CNAME not really necessary and slower than A records for the DNS resolution in the end. Just can use two A records with your IP address.


Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Looks like the error was related to the fact that the server was not configured with SSL. The HTTP requests would always redirect to HTTPS and so the error I reported would happen.

In order to apply SSL to my server, I changed my project structure while following this tutorial: https://www.digitalocean.com/community/tutorials/how-to-install-wordpress-with-docker-compose-pt

Now everything is working as expected :)

Hi @myopp,

Firstly, can you confirm if you are using the One-click app or have you installed everything on the droplet yourslef?

If you have configured the droplet on your own, it would seem you haven’t added fecho.app in your vhost configuration of your WebService-Apache.

You’ll need to create the website fecho.app a vhost file. If you are unsure how to do so, please follow the following tutorial - https://www.digitalocean.com/community/tutorials/how-to-set-up-apache-virtual-hosts-on-ubuntu-18-04-quickstart

Regards, KDSys