Changing keyboard layout

  • Posted July 16, 2013

Hi, I’m currently running a VPS using Ubuntu. I’m trying to configure the console so I can type using an Azerty keyboard layout, however when changing the /etc/default/keyboard my VPS keeps using Querty, even after a reboot.

My /etc/default/keyboard file:

Any thoughts?


Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Awesome, glad to hear it worked :]

Thank your for the help! <br> <br>Seems like the problem only persisted on the webconsole, when I used the console on my local machine to SSH my server, Azerty worked fine.

If it’s already installed, you have to run “sudo dpkg-reconfigure console-setup” instead.

It says that console-data is allready the latest version, so no succes so far…

:sudo apt-get install console-data" - choose azerty when it prompts your for keyboard layout.

I get this result: <br> <br>uknowwn charset unicode - ignoring charset request <br>Loading /usr/share/keymaps/i386/azerty/fr.kmap.gz <br> <br>But it doesn’t change anything when I type.

Try running “sudo loadkeys fr” in the console - does that work?