Question

CNAME not working, www in general not opening my website

Hello, My wordpress website is “ogmashare.com”. Opening it via https://ogmashare.com works, http://ogmashare.com also works. but adding www. doesn’t.

Usually I never encountered this problem with digitalocean. I tried fixing it by adding a CNAME record that redirects to @ but it’s still not working.

Any help would be appreciated.


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Hi there @ravingsmads,

The problem is not really the DNS here, your CNAME record for www is setup correctly. You can check that here:

https://www.digitalocean.com/community/tools/dns?domain=www.ogmashare.com

The problem seems to be your SSL certificate, it only includes your non-www version. You need to re-issue SSL certificate so that it includes both the www and the non-www version of your domain.

If you are using certbot the command would look something like this:

  1. sudo certbot -d domain.com -d www.domain.com

Let me know how it goes! Regards, Bobby