Question

Connecting to Owncloud via DAV: failure to connect

I feel as though I am missing a setting here. The OC server works just fine in the webclient. However, when I attempt to use ANY dav client, the results are always “failure”. This is my first time using OwnCloud and any form of DAV. I have followed the directions to the OwnCloud documentation. However, when I try to connect using davfs, I get: /sbin/mount.davfs: mounting failed; the server does not support WebDAV. I have ~/.davfs2/secrets set as: 45.55.137.155/owncloud/remote.php/webdav user password (Username and password obviously redacted). fstab is set to *45.55.137.155/owncloud/remote.php/webdav /home/pi/owncloud davfs user,rw,auto 0 0 *.

So I am really lost now at this point and I don’t know where else to find help.


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

First, go to https://your_site/index.php/settings/apps then go to “Not Enabled”, scroll down to the bottom, and ensure WebDav isn’t disabled. If it is enable it.

By default, it’s disabled.

This comment has been deleted