Question

Control panel does not recognize agent was updated

A few weeks ago, I tried upgrading my do-agent so as to get the hard-disk space monitoring & alerts feature. The control panel still lists “New! Upgrade your Droplet for additional metrics and alerting.” Today I tried again, uninstalling and re-installing the agent, but even a couple hours later I still am not getting the updated metrics (the old ones continue to work though)

My version appears to be up to date, but the control panel won’t recognize it.

root@elastic:/opt/digitalocean/bin# ./do-agent --version

do-agent (DigitalOcean Agent)

Version:     3.5.6
Revision:    7dadc14
Build Date:  Mon Aug 12 14:45:50 UTC 2019
Go Version:  go1.12.1
Website:     https://github.com/digitalocean/do-agent

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Hello, @sim9

As long as you have the latest version running on your droplet everything should be okay it with it. I will suggest to contact our support team and they should be able to shed more light on this.

Hope this helps Alex