Question

database error code: max_allowed_packet

error code: #1153 - Got a packet bigger than ‘max_allowed_packet’ bytes my db size:1.8 gb normally 84 mb zip setting:256M you can help me please


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Hey there,

You would want to make sure that your /etc/my.cnf file included the line of max_allowed_packet=100M. You would want to restart MySQL and if you were importing a new database, you would also need to include a –max_allowed_packet flag.

Example:

  1. mysql --max_allowed_packet=100M -uroot -p db_name < db_export.sql

Happy coding,

Jon Schwenn Platform Support Specialist DigitalOcean