Question

DKIM pass, SPF pass, DMARC pass but the email goes into Gmail spam

Hi people,

I’m setting up my email server. I setted DKIM, SPF and DMARC but the email goes every time in the gmail spam folder. Everything seems correct, the score for spam is 0.11 and in the original message DKIM, SPF and DMARC pass. These are the headers

Delivered-To: REMOVED@gmail.com
Received: by 10.180.188.98 with SMTP id fz2csp1245739wic;
        Fri, 22 May 2015 08:44:47 -0700 (PDT)
X-Received: by 10.180.104.197 with SMTP id gg5mr8856620wib.27.1432309487527;
        Fri, 22 May 2015 08:44:47 -0700 (PDT)
Return-Path: <info@mydomain.com>
Received: from server01.mydomain.com (server01.mydomain.com [46.101.x.x])
        by mx.google.com with ESMTP id q3si9502543wix.19.2015.05.22.08.44.47
        for <REMOVED@gmail.com>;
        Fri, 22 May 2015 08:44:47 -0700 (PDT)
Received-SPF: pass (google.com: domain of info@mydomain.com designates 46.101.x.x as permitted sender) client-ip=46.101.x.x;
Authentication-Results: mx.google.com;
       spf=pass (google.com: domain of info@mydomain.com designates 46.101.x.x as permitted sender) smtp.mail=info@mydomain.com;
       dkim=pass header.i=@mydomain.com;
       dmarc=pass (p=QUARANTINE dis=NONE) header.from=mydomain.com
Received: from mail-oi0-f42.google.com (mail-oi0-f42.google.com [209.85.218.42])
	(using TLSv1.2 with cipher ECDHE-RSA-AES128-GCM-SHA256 (128/128 bits))
	(No client certificate requested)
	by server01.mydomain.com (Postfix) with ESMTPSA id DD89DDF501
	for <REMOVED@gmail.com>; Fri, 22 May 2015 17:44:45 +0200 (CEST)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/simple; d=mydomain.com; s=mail;
	t=1432309486; bh=+KHvtyeJP12iMLhZ2tcRLR7J2aLEi9eaRrYBnjD6yFI=;
	h=Date:Subject:From:To;
	b=pGvGHzZdRbL7T1LBkKqO64kdXRNVQr7MdOAax551QiHV3T8jekdrl8Td2fW5V19Q8
	 VkESxCnBiaDkMLtq43nHim+A7MBdvrnglfAT9OXvlnS3Ve3rKA/+qlRHkupc0/u9X5
	 qVOW7lN7Nj3XqF0p4k0EX6jELHqnIFZW6ucauGx0=
Received: by oige141 with SMTP id e141so16836307oig.1
        for <REMOVED@gmail.com>; Fri, 22 May 2015 08:44:44 -0700 (PDT)
MIME-Version: 1.0
X-Received: by 10.182.153.74 with SMTP id ve10mr4675484obb.54.1432309484766;
 Fri, 22 May 2015 08:44:44 -0700 (PDT)
Received: by 10.202.173.204 with HTTP; Fri, 22 May 2015 08:44:44 -0700 (PDT)
Date: Fri, 22 May 2015 17:44:44 +0200

How can I solve this?

Thanks!

Show comments

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Hello there,

What you can try is to split the record into two parts using quotes and then run another test via mail-tester.com or mxtoolbox. In this way, you can check if the record is valid and if it’s a case of DNS cache and the record not taking immediate effect.

You can also check our article on Why You May Not Want To Run Your Own Mail Server

https://www.digitalocean.com/community/tutorials/why-you-may-not-want-to-run-your-own-mail-server

Regards, Alex

Same issue with my droplet. Anyone has a solution yet?

Hi,

Yes, i definitely solved, but since that i reconfigured the whole droplet i don’t know what really worked