do-agent exited with a return code 100

Hi there,

Lately, I’ve been getting messages at the start of every month to my root email with the following message after updating the DigitalOcean monitoring agent:

run-parts: /etc/cron.daily/do-agent exited with return code 100

Do I need to be concerned with this? I tried Googling, but there is no information about a return code 100 on here.


Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

I’m having the same issue lately.

I run time /bin/bash -x /opt/digitalocean/do-agent/scripts/ to find out about the problem.

Created a db dump and a restore point.

Then needed to reinstall mysql-server by running these

sudo apt-get purge mysql-server
sudo apt-get install mysql-server

I’m having the same issue lately.

@terresquall I hope you’ve figured a fix by now, but if not, the following post seems promising:

I’m having trouble with this as well, my first indication being early this morning. I’ve not yet worked through the same steps as the author of the post I linked, but I will soon.


You can check the cron log as well, you might be able to see a more detailed error in there. You can check the last 100 rows in the cron log with this command:

tail -n 100 /var/log/cron