Domain not loading to correct document root after mail gun setup

April 1, 2016 1.3k views
Ubuntu Apache

I just setup mailgun for one of my domains on my droplet. Everything seems to be correct however my domain is now loading to the /var/www directory and not my custom directory /var/www/site.com/public_html declared in my site.com.conf file. It seems as if apache is just completely ignoring it, as far as I know all I changed was the DNS settings by adding all of the appropriate mailgun requirements.

Any help would be greatly appreciated!

  • Tyler
1 Answer

Hello,

This sounds like something else is taking precedence over your .conf file. Can you check the /etc/apache2/sites-enabled folder for any other files referencing your domain? There is likely one there that’s setting the root to /var/www

If you modify that file and then restart Apache, things should go back to normal.

Have another answer? Share your knowledge.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!