Question

Error using Drush with new Drupal installation of Drupal 8

I created a new server with Drupal 8 preinstalled. It already had Drush installed but whenever I run drush with a command in the working drupal directory I get the following error:

Command needs a higher bootstrap level to run-- you will need ot invoke drush from a more functional Drupal enviroment ot run this command.

I haven’t been able to get drush to work at all with this Drupal 8 install. I have used Drush regularly on Drupal 7 install with no problems.

Full message below: Command pm-update needs a higher bootstrap level to run - you will [error] need to invoke drush from a more functional Drupal environment to run this command. The drush command ‘pm-update’ could not be executed. [error] Drush was not able to start (bootstrap) the Drupal database. [error] Hint: This may occur when Drush is trying to:

  • bootstrap a site that has not been installed or does not have a configured database. In this case you can select another site with a working database setup by specifying the URI to use with the --uri parameter on the command line. See drush topic docs-aliases for details.
  • connect the database through a socket. The socket file may be wrong or the php-cli may have no access to it in a jailed shell. See http://drupal.org/node/1428638 for details.

Drush was attempting to connect to: Drupal version : 8.2.4 Site URI : http://default Database driver : mysql Database hostname : 127.0.0.1 Database port : Database username : drupal Database name : drupal PHP configuration : /etc/php5/cli/php.ini PHP OS : Linux Drush script : /usr/local/bin/drush Drush version : 8.1.2 Drush temp directory : /tmp Drush configuration : Drush alias files : Drupal root : /var/www/html/drupal Drupal Settings File : sites/default/settings.php Site path : sites/default Sync config path : sites/default/files/config_zHcDrPgGJYeXy 3dKR7o7v4Wq1ri3InXTfQqf-Esa47nOYgxjayXJ9 AMLKafTtmgdzS-JkIJ_Ow/sync


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

I ran into the same issue. I updated the password in my .my.cnf file to the password found in the settings.php file for the database.

http://drupal.stackexchange.com/a/125630

Digital ocean support found this solution and I can now update with Drush.

Basically, to resolve this log in as root, and make sure you’re in the root user’s home directory:

cd ~

After doing this, move the .my.cnf file to rename it:

mv .my.cnf backup.my.cnf

Hi, I think that u run drush outside drupal installation / root folder. Drush needs either to run in drupal installed folder or aliases to be configured to point that folder.

Please cd to drupal folder and run drush

cd /your/drupalrootfolder/