Error when I tried to delete folder on space

Error below when I tried to delete folder on space:

“Sorry, your directory could not be deleted.”


The error appears when I try to delete a folder on web interface. I deleted item by item, after 1.000 items deleted, I get deleted the folder without error

Hello, @danilodene

Could you please let me know if you’re deleting the folder manually from the DigitalOcean control panel or using an API request?

Regards, Alex

Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Accepted Answer

Hello, @danilodene

You can easily delete folders using s3cmd from your PC. s3cmd is a popular cross-platform command-line tool for managing S3 and S3-compatible object stores.

You can check our tutorial for configuring s3cmd:

Once s3cmd is configured you can use the following command to delete a folder:

s3cmd del s3://BUCKET/OBJECT


s3cmd del -r s3://sammy-test/TestFolder

If this is successfull the output should be:

delete: 's3://sammy-test/TestFolder/'

Hope this helps!

Regards, Alex

Same issue here, is this going to be fixed because I can not delete my folders.

I also have filezilla pro connected to my space, this also fails to delete folders.

I also tried s3 for windows to find it is only a trial version so removed it immediately.

Can we have a better long term solution or maybe you can just fix the issue please before we exceed the 250gb and incur additional charges for storing data we are unable to remove.