Question

Force web console to CLI and not GUI

I recently added a VNC server to my droplet. Now when I use web console I no longer have access to CLI and console takes me straight to GUI login which is not working and is unresponsive (blank screen). I have tried in different browsers and also in private mode.

How do I get the command line back in web console so that I can log in to my droplet?


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Hi,

You can disable GUI at system startup. Before you start modifying system settings, I recommend creating a snapshot of your droplet. You would be able to restore droplet if something went wrong. Note that you will be charged for the time when snapshot exists. It is not expensive to have a snapshot for a short period of time, unless its size is huge.

Here are the the steps to disable GUI at system startup.

1. In DO control panel switch to recovery environment (Boot from Recovery ISO), and launch recovery console.

2. Choose from menu Mount Your Disk Image(something like /dev/vda1 should appear next to the menu item), and then enter Interactive Shell.

3. Change root directory for your droplet’s one. But before that, bind some system resources. Execute following commands

mount -o bind /dev /mnt/dev
mount -o bind /dev/pts /mnt/dev/pts
mount -o bind /proc /mnt/proc
mount -o bind /sys /mnt/sys
mount -o bind /run /mnt/run
chroot /mnt

Now, your are in your droplet’s root directory. Be careful because you are acting as a root.

4. Disable GUI. Run the following command:

systemctl set-default multi-user

You should get a message like that:

Output
Removed /etc/systemd/system/default.target. Created symlink /etc/systemd/system/default.target → /lib/systemd/system/multi-user.target.

5. Exit your chrooted environment.

exit

6. Shutdown recovery environment

shutdown -h now

7. Switch to normal mode (Boot from Hard Drive). Launch DO console. CLI should be available again :)

Let me know how it works, pls.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

A big thanks … it worked!