Question

Ghost service does not run correctly

  • Posted on February 16, 2014
  • swrhimAsked by swrhim

I made a previous question, but it submitted without my details. When I type “service ghost start” in ssh, the service does not run. The return message is “Starting Ghost ghost” If i type “service ghost status”, it says that ghost is not running.

If I try to access my domain, I see the 502 bad gateway error. How do I debug this issue?


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Hi everyone, I am a noob here, so please bear with me. I tried upgrading from 0.4 to 0.5.1 but I am encountering the same thing. I tried the chown command but still nothing. When I type sudo service ghost start it says ok, but if I do a sudo service ghost status it says ghost is not running Hope anyone could help out. Thanks.

Check Ghost’s error log – are there any errors/info on why it’s crashing?

I just ran into the same issue. Ghost is not starting even after changing permissions…