how fix error: DNS problem: SERVFAIL looking up A for [domain]

the same error:


  • The following errors were reported by the server:

    Domain: Type: connection Detail: DNS problem: SERVFAIL looking up A for

    Domain: Type: connection Detail: DNS problem: SERVFAIL looking up CAA for

    To fix these errors, please make sure that your domain name was entered correctly and the DNS A/AAAA record(s) for that domain contain(s) the right IP address. Additionally, please check that your computer has a publicly routable IP address and that no firewalls are preventing the server from communicating with the client. If you’re using the webroot plugin, you should also verify that you are serving files from the webroot path you provided.

///////////////////////// **In my domain record is: **

  • type: A
  • Hostname:
  • Value:

the command is: /usr/local/letsencrypt# sudo ./letsencrypt-auto --apache -d -d

**How fix error? **


This comment has been deleted

Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

In the DNS control panel, the domain is called “”. Therefore, things like “” or “” don’t resolve, because they’re outside “”.

You need to rename the domain to “” (and create a “www” record in it).

If DigitalOcean doesn’t support renaming domains, you should add a new one and delete the old one.

I followed this link instructions:

(Pinged the domain name and typed the IP in Digital Ocean A record and got a 404 error, which is OK! Since I haven’t add any page to nginx server)

Try resetting DNS cache and then do it once again.

**thanks for answer **… but in my page section domain, exist record Hostname as : type: A and Hostname as, get same error with:

if run /usr/local/letsencrypt# sudo ./letsencrypt-auto --apache -d

**is same error. **

Add an A record for