Question

How to enable xml-rpc.php (redirrecting sudo)

Hello, I have xmlrpc.php disabled. I don’t remember How did I do it. When I type Mydomain/xmlrpc.php it redirects http://sudo/ and says this site can’t be reached. Can you guys tell me which way xmlrpc is disabled and how to enable it again?


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

I had the same problem. Remove /etc/apache2/conf-enabled/block-xmlrpc.conf and reload apache.

Hi there @levanmirvelashvili,

It sounds like that you might have a redirect setup for the xmprpc.php file.

I would recommend checking your Apache server block file for your domain name, it should be stored at: /etc/apache2/sites-enabled/yourdomain.com.

Also make sure to check your .htaccess file for any redirect rules.

Let me know how it goes! Regards, Bobby