Question

How to increase Request Timeout on App Platform?

I have a web application that processes Excel files. Sometimes, some excel files are bigger than usual and need a bit more time. However, the request times out after 30 seconds (Error Code 504).

Now, is it somehow possible to increase the timeout to, e.g. 45sec. / 60sec.? Please note, I am using DO’s app platform.

Thanks in advance.


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Hello,

I’ve recently answered a similar question here:

https://www.digitalocean.com/community/questions/gunicorn-increase-timeout-doesnt-takes-effect

Basically, setting the timeouts in the run command in the Procfile file should work:

web: gunicorn app:app --timeout 100

But note that there is a hard set 100s timeout in the App platform for requests that unfortunately can’t be changed.

However, if the request is timing out in 30 seconds that could be due to resource exhaustion.

Please reach out to our amazing support team who will be more than happy to assist you with this :)

https://www.digitalocean.com/support/

Hope that helps!

  • Bobby.