I am seeing complete blank/white page after I login to my DO account.

Not sure why?

I have a very old account and using many droplets from long time. Even, I’m not able to top-up.

I emailed support@digitalocean.com but haven’t received anything from them. DO support has always been fast....

Guys, please help.

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
6 answers

Hey @deepblue,

In our public community, we aim to answer open questions about anything SysAdmin, DigitalOcean and beyond. However, we make every attempt to keep personal information safe and so don’t ever access personal account information here. This means we can’t provide help with any account or billing-related issues.

Do you have a ticket number from when you contacted our support team so that I can get this followed up for you?

Hope that helps!
- Matt.

@MattIPv4

I didn’t know about that. It’s my first post ever in the community, as I don’t know how to get this resolved as they aren’t replying.

Ticket #03500227

Hi @deepblue ,

In some countries like Iran or China,their government has to execute Internet Inspection.Thus,DigitalOcean cloud dashboard will be like a blank page for not loading CSS resources properly,as it’s using Fastly (Sometimes blocked in the countries have Internet Inspection) to accelerate them,so maybe it’s not a problem with DigitalOcean.If you are in these places,please check your browsers’ console (F12 to open) to see if there is any error and then take a screenshot to let us know more about this.

Kind regards,
Shiroka

I am also facing the same problem. Its start yesterday.

It’s an IP issue by the ISP.

Maybe, maybe.. IP6.

The simplest way to get this resolved was to change DNS to Google’s.

8.8.8.8
8.8.4.4

You can search online to how to do it.

@deepblue Thank you, problem solve after changing ISP.

Submit an Answer