canada
By:
canada

I can't access my site but everyone else can (only my IP address doesn't work)

December 28, 2015 1.7k views
Nginx PHP Ubuntu

Hey everyone. First post!

So I cannot access my site unless I use a VPN or use another WiFi network. For some reason, it's not allowing me to access my own site using my own IP. If I connect from my phone using my data, it works fine. It seems to be only my IP address.

I have no idea why this is happening.

No idea what's happening. Any help is appreciated. I'm using Laravel on Forge.

1 comment
  • My first guess would be cached DNS results on your WiFi router. (this is assuming you are trying to connect to your droplet via a domain or subdomian name rather than it's IP address).

    When you connect to a router via DHCP DNS settings are passed to your computer. Often these will point either to your ISPs own nameservers or to a proxy or private name server on your router. In either case, if you had been accessing your site at another location (or just registered the domain) these records may be out of sync with what the rest of the Internet sees. If this is the case it should clear up on it's own within 24 hours as the DNS server's cache expires. In the short term I would recommend changing your DNS server settings to 8.8.8.8 (Google's public DNS server) and trying again.

1 Answer

This question was answered by @ryanpq:

My first guess would be cached DNS results on your WiFi router. (this is assuming you are trying to connect to your droplet via a domain or subdomian name rather than it's IP address).

When you connect to a router via DHCP DNS settings are passed to your computer. Often these will point either to your ISPs own nameservers or to a proxy or private name server on your router. In either case, if you had been accessing your site at another location (or just registered the domain) these records may be out of sync with what the rest of the Internet sees. If this is the case it should clear up on it's own within 24 hours as the DNS server's cache expires. In the short term I would recommend changing your DNS server settings to 8.8.8.8 (Google's public DNS server) and trying again.

View the original comment

Have another answer? Share your knowledge.