I can't configure Ghost 1-click droplet. It keeps getting error.

For the domain, I pointed both @ and www to the Droplet IP.

The first errors come up when I enter the domain on the setup. I first tried It says it is not pointed. I next tried It gets the same error. When I entered, it continued to nginx installment. Then I got “ProcessError” with the following message:

Message: Command failed: /bin/sh -c sudo -S -p '#node-sudo-passwd#'  /etc/letsencrypt/ --issue --home /etc/letsencrypt --domain --web                                                                             root /var/www/ghost/system/nginx-root --reloadcmd "nginx -s reload" --accountema                                                                             il
[Wed Oct 21 11:17:29 UTC 2020] error:Invalid responsefrom                                                                             GP0domHlrhfOR73ijZs5thE []:
[Wed Oct 21 11:17:29 UTC 2020] Please add '--debug' or '--log' to check more details.
[Wed Oct 21 11:17:29 UTC 2020] See:
[Wed Oct 21 11:17:19 UTC 2020] Using CA:
[Wed Oct 21 11:17:20 UTC 2020] Create account key ok.
[Wed Oct 21 11:17:20 UTC 2020] Registering account:
[Wed Oct 21 11:17:22 UTC 2020] Registered
[Wed Oct 21 11:17:22 UTC 2020] Creating domain key
[Wed Oct 21 11:17:22 UTC 2020] The domain key is here: /etc/letsencrypt/
[Wed Oct 21 11:17:22 UTC 2020] Single domain=''
[Wed Oct 21 11:17:22 UTC 2020] Getting domain auth token for each domain
[Wed Oct 21 11:17:24 UTC 2020] Getting webroot for domain=''
[Wed Oct 21 11:17:25 UTC 2020] Verifying:

What could be the problem here?

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Have you tried pointing a domain to your droplet and then configuring the domain and adding SSL to it ?

After pointing a domain your droplet, login to SSH

Switch to the ghost manager user:

sudo -i -u ghost-mgr

cd in to your ghost directory (default is /var/www/ghost)

cd /var/www/ghost

Set the domain for Ghost - > Run:

ghost config url.


ghost setup nginx ssl

Switch blog URL to SSL address

ghost config url.


ghost restart

@KFSys @denislavgavrilov is a placeholder for my real domain. Turns out there is an issue when using this 1-click when using SSH. It worked when I used password.

Hey there @johnrick,

This may seem like a stupid question but… by you are entering the name of your domain, right? For example, if I want to set it up on my domain, I would input

My idea is - you are entering your domain, and not the word mydomain?

Best, Dennis