I cant access my website after i setup ikev2 vpn in same droplet?

So I followed this guide in setting up my personal vpn on the same droplet which contained my website.

Now the vpn works but my website doesn’t work anymore.

I tried enabling ufw again but still doesn’t work.

Luckily I made a snap of my droplet before doing it.

I’m just here to know if it is possible to do it or not.

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Accepted Answer

I used this guide/tut:—-configuring-strongswan

Everything’s working fine now. I have fixed it.

I first restored from a snap.

What went wrong was that at my first install (I’m using putty here), i put the host name as my domain then log on to my sudo user there and this where the website did not load.

On second attempt and the fix: I ssh using my site’s ip address instead of the domain and installed everything and all of it works fine.

Website now loads and the vpn works.

I know I was stupid to ssh through my domain. Haha So yeah… Maybe someone out there made the same mistake as mine, I’m just putting this here.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.