I closed the 22 SSH port now i cant connect to it

I’m having a problem with the connection after I closed port 22 by mistake. now I can’t connect to the host and this is the error that occurred when I try to connect " ssh: connect to host port 22: Connection timed out " to solve it I’ve tried o use the Recovery Console but for some reason, I can’t open the terminal how do I solve this problem? thanks in advance

PS: I’ve tried to use the recovery console but it has a problem and because of it I can’t access the terminal inside it

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Hi @HidingTealAnemone,

The only way is to use the Recover Console. There are two ways to go about it though. You’ve found the docs but just in case here they are :

Alternatively, you can use the Droplet Console. Use the Droplet Console for native-like terminal access to your Droplet from your browser. Here is the list of supported OSes for the new console.

To enable the Droplet Console, log in to your Droplet as root or as a user with sudo access. Once connected, download and execute the agent installation script with the following command to enable the console immediately:

wget -qO- | sudo bash

Those two are the only options I see.