Increasing max file size in PHP

Ubuntu 16.04 running nginx and php7.

I’ve tried multiple changes to the fpm/php.ini to increase ‘upload_max_size’ and ‘post_max_size’, but none of my changes appear in a phpinfo() that I added to the webserver.
I located all the other php.ini 's that are on my server and updated them to match, but no changes seem to get pushed to the server after restarting php and nginx.

In all of the ini files, I have

post_max_size 25m;```

My nginx configuration has a much higher value for client_max_body_size than either of these values, but no changes successfully appear in phpinfo().

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Accepted Answer

Ended up reinstalling php and nginx. After doing so, I was able to modify the configurations and restart with changes appearing successfully.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.



You can create a php info file in order to check the current values and check which is the php.ini file in use. Create the following file in your public_hmtl folder - phpinfo.php and put the following code inside it:


You can also use the following command in order to find the location of the php.ini file:

php -i | grep php.ini

The output will be:

Configuration File (php.ini) Path => /etc/php/7.2/cli
Loaded Configuration File => /etc/php/7.2/cli/php.ini

Then check for the current value of uploadmaxfilesize you can also check which is the configuration file - php.ini that is currently used and apply the changes there (if the site using the global php.ini file and you change the values for these settings this will make the changes globally for all sites). Ideally you would like to have the following values:

upload_max_filesize = 64M

You also need to restart your web server in order the changes to take effect.

Hope that this helps! Regards, Alex

make a new file with name php.php and add the code



and share the output

sudo service nginx restart && sudo service php7.0-fpm restart

This will restart both services and load the new configurations. If there are any errors the restart will fail.