Question

iptables in place, but ports are not open!

Below is my iptables output. Depite this, the only port I can access is 58580. Ports 80, 2086, etc are not open.

Chain INPUT (policy ACCEPT) target prot opt source destination ACCEPT all – anywhere anywhere ctstate RELATED,ESTABLISHED ACCEPT all – anywhere anywhere ACCEPT tcp – anywhere anywhere tcp dpt:http state NEW,ESTABLISHED ACCEPT tcp – anywhere anywhere tcp dpt:http state NEW,ESTABLISHED ACCEPT tcp – anywhere anywhere tcp dpt:http limit: avg 25/min burst 100 ACCEPT tcp – anywhere anywhere tcp dpt:2082 state NEW,ESTABLISHED ACCEPT tcp – anywhere anywhere tcp dpt:2083 state NEW,ESTABLISHED ACCEPT tcp – anywhere anywhere tcp dpt:gnunet state NEW,ESTABLISHED ACCEPT tcp – anywhere anywhere tcp dpt:2087 state NEW,ESTABLISHED ACCEPT tcp – anywhere anywhere tcp dpt:58580 state NEW,ESTABLISHED

Chain FORWARD (policy ACCEPT) target prot opt source destination

Chain OUTPUT (policy ACCEPT) target prot opt source destination ACCEPT all – anywhere anywhere ACCEPT tcp – anywhere anywhere tcp spt:smtp state ESTABLISHED ACCEPT udp – anywhere anywhere udp dpt:domain


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

nginx, and I restarted it to make sure it was up before checking. <br> <br>I will have to retrace my steps for the nginx setup. Not sure what else to do. <br> <br> thanks for your help

There doesn’t seem to be anything listening on port 80 – do you have a webserver running?

If I flush the iptables, I still cannot reach the server. If I use a port check utility, 80 and all ports are closed except my telnet port.