Question

Keep getting 404 after a while, changed DNS yesterday

I’m having a weird issue where my website will work fine and then it will randomly 404 on all pages. Eventually it seems to fix itself until it “crashes” again.

I used serverpilot.io to set up the LAMP stack, and have added custom DNS settings early yesterday to point my domain at my server IP. It should all be propagated by now as it’s been over 24 hours. I am developing my site in an obscure sub-folder (not the root) which due to serverpilot resides here: /srv/users/serverpilot/apps/wordpress/public

Since my wordpress installation is in a folder in that location, it should be working. But it will get a 404 after a while and I can’t continue any work.

This is what my DNS looks like:

I have no idea what is really happening or the reason, I’m not so great at command line or linux, so just let me know any more info you’d need or how to find it.

**Edit: **I can also confirm that the website DOES load properly on my laptop… so it’s a problem with my machine? Well I’ve tried flushing the DNS, deleting cache. No luck. Thanks!


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Well I guess I’m stupid. Lol. I was flushing my DNS, but low and behold it wasn’t running “as admin”. So I fixed it with this:

Win+x, select “command prompt run as admin”

ipconfig /flushdns

I’ve got my fingers crossed that it doesn’t keep happening.

This comment has been deleted