ld-linux-x86-64 process CPU High

Hi, I have a problem. CPU is always between 90%-100% even after i reboot the system. When i run top i see a process called ld-linux-x86-64 with CPU at 99% for user deploy.

What should i do? What is ld-linux-x86-64?

Show comments

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

I am also facing the same problem as below is the output of pstree of my server. Please help to resolve this issue. I have tried to increase my CPU resources but still that process is eating up all CPU resources.

|-irqbalance |-java—13*[{java}] |-ld-linux-x86-64—7*[{ld-linux-x86-6}] |-6*[mingetty] |-mysqld_safe—mysqld—19*[{mysqld}]

This is most likely other applications or processes that are running through the process you are seeing. Try running pstree to see all subprocesses under the process you’re seeing with top.