MongoDB Compass timeout

I trying to connect my Managed MongoDB DigitalOcean Database with my VPC Network but when I try to connect, I get:

connect ETIMEDOUT 10.x.x.3:27017

I tried allow all sources on my trusted sources and with my IP on trusted sources and both failed.

I tried with Public network and I get:

Authentication failed

PS.: I got the connection string from Digital Ocean

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Rajkishore J
DigitalOcean Employee
DigitalOcean Employee badge
October 18, 2023

Hi @imerik1

Can you check if you have added correct IP address to trusted source using this link : and then try again to connect?

If IP address is correct and still you are seeing errors then please reach out to DigitalOcean support so that we can check further on why you are facing this issue.

Regards, Rajkishore J

Try DigitalOcean for free

Click below to sign up and get $200 of credit to try our products over 60 days!

Sign up

card icon
Get our biweekly newsletter

Sign up for Infrastructure as a Newsletter.

Sign up
card icon
Hollie's Hub for Good

Working on improving health and education, reducing inequality, and spurring economic growth? We’d like to help.

Learn more
card icon
Become a contributor

You get paid; we donate to tech nonprofits.

Learn more
Welcome to the developer cloud

DigitalOcean makes it simple to launch in the cloud and scale up as you grow – whether you’re running one virtual machine or ten thousand.

Learn more ->
DigitalOcean Cloud Control Panel