My droplet become irresponsive after some time

I am working on a rails app in which I 'm using Sidekiq to make the process of sending email on sign up Asynchronous(I have installed Redis on my local server). Everything work fine in development mode.

But When I deployed it to Digital Ocean Droplet. It worked fine except email sending, So I installed Redis on digital Ocean and it solved the mailing issue.

Almost after a day Digital Ocean Server became irresponsive, when I try

ssh root@Server-IP

it givesConnection timed outerror.

It has happened twice in couple of weeks. Last time it happened, It didn’t even allow to delete droplet. But Somehow my team lead created a new droplet. I installed everything and than deployed my rails app to it, it worked fine for almost a day and than became irresponive too.

Why its happening, It has anything to do with Redis?


If you were unable to delete your droplet via the control panel this would indicate a deeper issue than your configuration. I strongly recommend opening a support ticket so our team can investigate.

Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Like @ryanpq stated your best bet is to open a support ticket so they can investigate it, but next time it errors like that I would recommend restarting it or power cycle the droplet in the control panel if possible