My Server is down with error: file '/boot/grub/i386-pc/normal.mod'

When I try to launch the console from panel I get this error: file ‘boot/grub/i386-pc/normal.mod’ not found. And prompt of “grub rescue” comes. I have no idea how to resolve this issue. Here is what I have tried so far: 1. I tried this option 2. The above links suggested to change the prefix I tried, but it didn’t worked, here is the output of ls. grub rescue> ls (hd0,gpt1)/boot ./ …/ efi/ grub rescue> ls (hd0,gpt1)/boot/efi ./ …/  NO FILES/FOLDER inside efi folder and there no grub folder as well. So I think grub is removed. And I have no idea why/how.

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

I am also having this issue as of 2-3 days. No idea how or why it happened.