new email address not forwarding

I’ve just moved a new domain ( over to Digital Ocean, creating the A records and then updating the registrar ( of the change. After a few minutes, nslookup and dig confirm that the change has propagated. Checking the apache logs, I’ve also confirmed that web pages are now being served from Digital Ocean. So far so good.

Now to forward email sent to a few addresses. This is currently handled by my current ISP, but I’d like to do this through DigitalOcean. I added a new A record for mail, as well as an MX record, and then updated /etc/postfix/ to include the new domain under virtual_alias_domains, and a pair of new email aliases in /etc/postfix/virtual. I ran “newaliases”, reloaded and restarted postfix, but I’m still getting an error when sending an email to “”:

Delivery to the following recipient failed permanently:

Technical details of permanent failure: Google tried to deliver your message, but it was rejected by the server for the recipient domain by [].

The error that the other server returned was: 550 5.1.1 Recipient address rejected: User unknown in virtual alias table

Is there something wrong with the way I’ve set up the alias?

Here is the contents of /etc/postfix/virtual. I can confirm that is forwarding correctly.

root@pescadero:/etc/postfix# cat virtual

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

This issue is resolved. I must have missed the step to run the following two steps in this order, after which things began to work as expected.

postmap /etc/postfix/virtual postfix reload