Question

New monitoring script not working- best way to debug?

I followed the instructions to update my monitoring script as the old ‘do-agent’ is deprecated. However, for some unknown reason, the install appears to have failed as I am no longer getting monitoring. This is on Ubuntu 14.04, is that OS version supported? I plan to move to 18.04 shortly but in the meantime it would be nice to have the monitoring working… Any ideas?


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

After a little digging, I was able to determine the cause was an unrelated defunct entry in my sources.list. Once I removed it, the install script worked as expected. I also reported this issue to the do-agent repo over on GitHub.

Greetings!

Thanks for posting this here. It should work fine on Ubuntu 14. Do you have ports 80 and 443 open for outbound traffic from your droplet? That may be key for the do-agent to submit the data to our server. You can also reach out to our support team and have them check the last time that the do-agent reported in successfully from your server.

https://www.digitalocean.com/company/contact/#support

Jarland