No internet after backup restore in a new Droplet on Ubuntu 18.04

I restored a backup in a new droplet. I mean, I kept my main droplet working while I restored a backup of that droplet in a new droplet with a new different IP. The problem is that the new droplet does not connect to internet, I cannot ping other ips on internet and it does not respond to ping

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

I finally solved the problem. I think the problem was that my new droplet was trying to use the other Droplet ip. I did the following, in the directory /etc/netplan there were two files:


I noticed that interfaces.yaml did reference the ip of the other droplet, so I deleted it. Then I run the following commands:

sudo netplan generate
sudo netplan apply