Not receiving emails of my account AT ALL, including the root pass of new droplets, etc. Any suggestions???

  • Posted January 17, 2015


I am really exhausted here. I am not able to receive any email of my account, from the first moment I registered.

Actually - I can’t do anything with my new Droplet, as I don’t have the password to access it.

I tried to change the email, but it try to send the conformation request for changing e-mail, to my current email, and as I said - I am not receiving any emails!

In the bottom line, I am STUCK :(

Any suggestions??? Please HELP! P.s: I have opened Support Ticket but nothing changed until now…


I have the identical problem which first occurred about a week ago - prior to that I was having no problem - but DO support have suggested its a problem my end and they are no longer interested in the problem as looks to be the case for above post.

Tonight I tried opening a new test account using a non business email account - via a complete different ISP and different computer - and absolutely nothing - no confirmation email has been received despite a RESEND request several times.

If you check is showing 5 mail server warnings so the problem could be that “Reverse DNS does not match SMTP Banner” ?

I must admit if they don’t respond to my ticket very soon then I am transferring to Rackspace and while they are more expensive at least they have three channels of support :- ticket; online chat & phone.

Same problem here… I am not receiving any emails

I am facing same problem. Tried destroying droplet, changing email, resting root password, but still not receiving anything

Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Hey, droplets emails are not coming…

-Fabio Hoje Digital

Same problem here. Need to access urgently to create dropplets to start project, a week trying without success