One postfix server - two domains, GMAIL marking e-mails as spam on one, the second not (same settings)

Hi, I am running postfix mail server with two domains - same settings (SPF pass, DKIM pass). E-mails from ONE domain are marked as spam by gmail mailboxes. The second domain is fine.

Any suggestions? Thanks in advance!


Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Hi @KDSys,

Thank you for your input, I already tried the prior to starting the topic, I always get 9/10 and 10/10 results (the minus points are for an HTML signature in the e-mail). However still, from one domain on the server, the e-mails are being marked as spam in some gmail accounts whereas other domains on the server do not have the same issue…

I realized that I did not have _dmarc/dkim set up on other e-mails that are being run on the server, so I set it all up and give it a couple of days to see if some other domain was not causing gmail to flag the server as a “spammer”…

It was a great help ! Thank you very much for sharing this !

Hi @totojsoumedia,

Hmm, this does sound weird. One of the possibilities is the IP of the Droplet check if it’s actually considered as a threat due to some reason.

Additionally, I’ll recommend using an e-mail checker to see if there are infact no differences between both domains and messages. The link is here - The way it works is you send a message to the given e-mail account and check the score of your message. It will provide you with a scale from 1 to 10 and notify you about any issues you might need to fix.

Try it out and see if after making a 10/10 score on the tester the messages will still be marked as spam.

One other thing, you know content does matter and it’s possibly Gmail are marking your messages based on it.

Regards, KDSys