OpenVPN in DO Marketplace is broken

June 11, 2019 317 views
Initial Server Setup

Try this:

Create a new Droplet. Choose OpenVPN from Marketplace, Standard Droplet ($40) in Singapore, and don’t use SSH key.

After the server is provisioned, SSH using Web-based console with the root password that was emailed to you.

Follow the steps, ENTER-ing everything (accepting default values).

Set password for “openvpn” user (this instruction is mentioned in the email from DO).

Log in using “openvpn” and the password you set.

You will see the license. Click Agree.

You will be thrown back to the login screen. Whaaaattt?

2 comments
  • Hello,

    Sorry to hear you’re having problems. Both DigitalOcean and myself personally and our support personnel have deployed a droplet with our image, and it works perfectly fine. The issue you describe cannot be reproduced here.

    My guess is there is something like a browser issue or antivirus or firewall blocking the login attempt somehow. It’s also possible, and I’ve seen this in the past, that the timezone and/or time/date settings on the server and/or client are set wrong, causing session to be timed out before they are supposed to time out. So check that time and date are correct and also try logging in from an entirely different device to see if that works better for you.

    If you continue experiencing problems, you should contact our support department on our openvpn.net website and send in details like log files and the exact steps you’re taking so we can make an attempt again at reproducing the problem so we can then fix it. At the moment, we can find no issue, however, with the information available to us now.

  • Thanks for the reply. I tried using my phone and it works. Now I log in using the same browser (Chrome on Windows 10), and now it works (because I have clicked “Agree” on the license screen from my phone).

1 Answer

This question was answered by @t88f6fdc3952d0af46f2b8546b:

Thanks for the reply. I tried using my phone and it works. Now I log in using the same browser (Chrome on Windows 10), and now it works (because I have clicked “Agree” on the license screen from my phone).

View the original comment

Have another answer? Share your knowledge.