Question

Production SMTP Gmail settings

He everyone, i’m trying to implement Devise her “forgotten password” method into my application. Sadly i’m getting the message “check the production logs”, but there is nothing there.

My Production.rb:

config.action_mailer.default_url_options = { host: 'http://..' }
  config.action_mailer.delivery_method = :smtp
  config.action_mailer.perform_deliveries = true
  config.action_mailer.smtp_settings = {
      :address              => "smtp.gmail.com",
      :port                 => 578,
      :domain               => "gmail.com",
      :user_name            => "..@gmail.com",
      :password             => "..",
      :authentication       => :login,
  }

In Gmail settings i have the “Allow less secure apps: ON” part turned on aswell.

Any tips or advice would be greatly appreciated!

K.


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

you can check your all email settings, imap settings, smtp settings click here

For production environment in /config/environments/production.rb you may use something similar to the following (supposing you have a SMTP server on localhost:25):

config.action_mailer.default_url_options = {:host => 'yourdomain.com'}
config.action_mailer.delivery_method = :smtp
config.action_mailer.smtp_settings = {
  :address => "127.0.0.1",
  :port    => 25,
  :domain  => 'yourdomain.com'
}

In development the forgotten password email works fine, except production.