Rails app under subdomain returns blank page

  • Posted November 8, 2014
  • I have a domain with godaddy : This is the main domain, and has a website hosted on another hosting.

  • My rails app is deployed at digital ocean with Nginx-Unicorn-Ubuntu stack.

  • I created a sub-domain called, and pointed it to this droplet. I get the following response (on the browser):


<frameset rows="100%,*" border="0">
  <frame src="" frameborder="0" />
  <frame frameborder="0" noresize />

<!-- pageok -->
<!-- 04 -->
<!-- -->

I’ve tried to do some debugging, and the problem is definitely with the rails app.

What I tried, and some interesting results :

  • The app is showing when i enter IP address.
  • With the domain, I checked rails logs, and a GET request is hitting the app, and controller#view is being accessed
  • I’ve tried checking config files of nginx, unicorn. Absolutely no problems there. The request is hitting my rails app.

How do I get the page to show up with the subdomain? What’s going on here?


Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others. points to which is run by GoDaddy. It looks like you accidentally created a “forward” to the IP address instead of an actual DNS record for the subdomain, which explains the iframe pointing to your droplet’s IP address:

<frame src="" frameborder="0" />

You need to add a CNAME (Alias) DNS record instead, set the “Host” to support, and the “Points to” field to @ and make sure you delete the forward rule that you created using GoDaddy’s control panel.