macapa
By:
macapa

rebuilding from snapshot

October 2, 2016 304 views
DigitalOcean

I have a droplet serving a couple of websites.
Now I wanted to change some things and build a new droplet with all the changes I wanted to incorporate. I made a snapshot of this new droplet.
In order to not change the IP address and having to change DNS for multiple domains I want to rebuild on the existing droplet form the new snapshot.

Now when I try to rebuild the original droplet from this snapshot it does not show up in the rebuild box. It does show on my images overview.

How do I get the snapshot to show on the original droplets rebuild​ screen ?

2 comments
  • Are both, new and original droplet, in same region? This is pretty important, as you can only use images (snapshot) if they are in same region. If this is the case, you can change region by going to Images -> Snapshots, find your image -> More -> Add to Region -> Select region of original droplet :)

  • Yes they are both in the same region.

    I just figured it out.

    The original droplet was a smaller size (20 GB disk 1 GB RAM) which is not available anymore, so I could not use the snapshot with the 30GB. After resizing the original droplet to increase the disk size it was available and the rebuild worked.

1 Answer

This question was answered by @macapa:

Yes they are both in the same region.

I just figured it out.

The original droplet was a smaller size (20 GB disk 1 GB RAM) which is not available anymore, so I could not use the snapshot with the 30GB. After resizing the original droplet to increase the disk size it was available and the rebuild worked.

View the original comment

Have another answer? Share your knowledge.