Scale up as you grow — whether you're running one virtual machine or ten thousand.

From GPU-powered inference and Kubernetes to managed databases and storage, get everything you need to build, scale, and deploy intelligent applications.

By Shoeb Patel
I have an application API that works on Server-Sent Events (SSE, https://developer.mozilla.org/en-US/docs/Web/API/Server-sent_events/Using_server-sent_events).
It’s hosted in Managed kubernetes and exposed directly through Managed loadbalancer.
The Requests fail with “502 Bad Gateway”, “upstream connect error or disconnect/reset before headers. reset reason: protocol error”, although backend API shows 200 OK in logs.
As server-sent events are nothing but long-standing HTTP requests, there are ways to achieve it via increasing LoadBalancer <-> BackEnd SSE API HTTP connection timeout period.
I don’t see this option in DO LB though.
Ex. A workaround on GCP: https://stackoverflow.com/questions/44729212/running-a-https-sse-server-over-kubernetes-ingress-and-google-cloud-platform
1a3ca91ed97c49039b3e74fb7229fa
6efbf601fa8e49c884398e706c4672
f27857d3fd85405b8f50d9997c684d
petercorrea
ulope
josaf bodia
jediD83
rafaelri
Lucas Souza
Ben Buzbee
andreasAngler