Question

Setup Reserved IP for a Windows Droplet

So I spawned a new droplet and installed Windows. I know that it’s not officially supported, but I need IIS to run my apps.

Anyway, my issue is with the Reserved IP. I’m not able to make it work. According to the documentation when we assigned a reserved IP to a custom image, “the reserved IP is automatically mapped to the Droplet’s public IPv4 address instead of an anchor IP”

I already added my Reserved IP to my Ethernet instance under Advanced TCP/IP settings, but using it on my DNS records won’t work. It is also not responding to ping.

Anyone can help?


Submit an answer
Answer a question...

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Thanks @kfsys! So far, it seems to be working fine. There are few things I noticed are not working, like the monitoring, and just recently, I tried to create a new droplet from a snapshot as well as from a backup, but it keeps failing. So I think deploying production applications may not be a good idea.

By the way, are you an admin? I read from a few comments on some Windows topics here in community that:

"Unfortunately at this time we do not have native support for Windows OSs on Droplets. You may be able to achieve this however by creating your own custom Windows ISO image and then using that when creating your Droplet."

Based on my understanding, they do not have native support so users cannot choose a Windows image from the dashboard but should be okay if using Custom Windows ISO. Is my understanding of this correct?

KFSys
Site Moderator
Site Moderator badge
November 28, 2022

Hi @donph,

The IP is automatically mapped but on a Linux machine. Not sure if that would be done automatically on a Windows image. Try configuring a resolv.conf of some kind on your windows machine and specifying the nameservers there, it might be of some use.

Honestly, it’s one of the few occasions someone has installed Windows on this infrastructure and I’m very keen to see how it ends up working.