Spaces upload fails !

So I’ve been uploading files to DO-Spaces through my android application (asw-SDK). a few days ago everything was working perfectly fine, I was ABLE to upload files with my android app and with my browser drag-drop too… But suddenly everything stopped working…

The region is: fra1.

So just for the test I have created new DO-Spaces NY-region (nyc3) and tried to upload files on it, and all I can say, it works smooth…

But my previous storage-SPACES (fra1) still doesn’t work, can’t upload anything… So If my android app was published and live, that’s means that I would kinda lose all my ‘data (images,files)’ and the users would’ve gotten a really really bad experience…

So does anyone know what’s happening ?

Show comments

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Matt Cowley
Site Moderator
Site Moderator badge
August 16, 2019
Accepted Answer

This question was answered by @Nicotra and @efox:

Well, to be honest, after 3 days from not working, now it works again, I’m able to upload files again and etc… Well, at least DROPLETS are amazing haven’t had any issues since I joined DO :)

View the original comment

If you continue facing issues with your FRA1 Space, we’d love to know more in a ticket so we can investigate this on the backend. For your failed upload, just capture the request + response headers in your browser’s networking developer tools and send those results into us in a new ticket (

View the original comment

I’ve been having this same problem all morning. The files do not exist after upload but if we use Cyberduck on macOS we can successfully upload files and they do exist.

We even added patch that would attempt to download the document after upload but it would always fail. No idea what’s happening, we haven’t changed code related to this at all.

We are in the sfo3 region.

FWIW, generating new credentials didn’t work - in fact using them denied us all access to the bucket.

This comment has been deleted

    Try DigitalOcean for free

    Click below to sign up and get $200 of credit to try our products over 60 days!

    Sign up

    Featured on Community

    Get our biweekly newsletter

    Sign up for Infrastructure as a Newsletter.

    Hollie's Hub for Good

    Working on improving health and education, reducing inequality, and spurring economic growth? We'd like to help.

    Become a contributor

    Get paid to write technical tutorials and select a tech-focused charity to receive a matching donation.

    Welcome to the developer cloud

    DigitalOcean makes it simple to launch in the cloud and scale up as you grow — whether you're running one virtual machine or ten thousand.

    Learn more
    DigitalOcean Cloud Control Panel