SSH blocked for all droplet's only on my region.


For some reason, I got locked out of SSH access, and this is not at my droplet’s, I have tried everything, and I am sure this is a firewall block at DO’s level.

Here’s what I tried:

  • I tried to SSH to my droplet, takes forever then closes connection.
  • I tried to SSH from a different computer on the same network, it’s not working.
  • I tried to SSH from same computer on different network, it’s not working.
  • I tried to SSH to a server (outside DO) then from this server tried to SSH to my droplet, it works.
  • I tried to restore a snapshot that I had where everything were working, and then SSH again from my computer, not working.
  • I purchased another droplet with a completely different IP and access of course, and tired to SSH from my computer, it’s not working!
  • ping to any droplet, it’s not working.
  • website access in browser, working.

I think I’m being blocked at some level, I’ve created a ticket support, but DO tech teams says they don’t have such firewalls enabled.

Anyone had a similar experience? I’d appreciate the help.

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Yes, I created a droplet in a different region and it worked :)

This appears to have been a temporary issue. Create a new droplet in a different region.

Try creating a Droplet in a different region and see if you can SSH into the server. Also what error do you receive from SSH? Is it a time out error?