Hi, how are you?

I’m new to digitalocean and don’t understand much about servers.

But after much struggle I managed to create one and put my woocommerce to run

I got it all by using tutorials on the internet. But there is one thing I couldn’t find … When I try to login to my panel https: //159.65..: 8083 an SSL error pops up

I don’t know if I installed the certificate the right way or what’s going on …

Someone to give me a little strength?

edited by MattIPv4

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
2 answers

Hey,@johnnydemarch

The SSL message pops up because you don’t have a SSL installed for the IP address itself. Is there an option for you to access the server’s control panel by using the server’s hostname? If you have installed SSL for the server’s hostname, you can set/edit the virtual host in order to access your control panel using the hostname rather the IP address. In this way you wont see the SSL warning message.

Let me know if you have any questions.

  • Hey, thanks for your reply!

    “The SSL message pops up because you don’t have a SSL installed for the IP address itself”

    • Well, I followed some steps I founded on Google. I thought I had it because the address https://shishando.com.br is looking good.

    “Is there an option for you to access the server’s control panel by using the server’s hostname?”

    • How can I do that?

    I installed ssl using ssh connection - but I don’t know if I did right way!
    I just follow steps

    Is there a way to reinstall?

    • The SSL for your domain name is installed and looks completely fine. However you don’t have one for the IP address as this is not considered as best practice and it’s rarely used.

      You can either access your control panel via the IP address followed by the port and ignore the SSL warning or configure and access the control panel using your hostname.

      If you can let me know more about the server itself and control panel I can give you some directions on how to set this up (e.g server OS, control panel type and Web server).

      • Hum....

        I have tried install SSL like this:

        wget http://dl.mycity.tech/vesta/generate_ssl -O /usr/local/bin/generate_ssl
        
        chmod u+x /usr/local/bin/generate_ssl
        
        generate_ssl admin 159.65.248.193
        

        But is not work

        My configs is: Ubuntu 18.04.3 LTS / VestaCP

        Thats help?

        Thank you for your attention!!!

      • When I try connect without https, I am redirect https…

        • From what I can see you’ve installed the SSL for the IP address as well, but it’s just not trusted/Invalid.

          Could you please let me know if you’re using Apache or Nginx? As mentioned if you have a working hostname for your droplet/server you can use it to access Vesta by creating a virtual host for it on port 8083

Error is in just https (https://markimpacto.com) http working fine

  • Looking at the warning, the SSL is invalid. The common name is shishando.com.br

    Have you tried issuing/installing separate LE SSL for markimpacto.com? If that is correct I will suggest you to check the Apache config file and locate the ssl block for this domain name and check if the loaded SSL Certificate is actually the correct one.

Submit an Answer