Statsd installation on Ubuntu 14.04 issue. Unable to start service

Posted September 17, 2014 4k views

I’m a relative newbie to running ubuntu, but I have followed along with Justin Ellingwood’s fantastic tutorials for getting graphite and statsd setup to run on Ubuntu 14.04. (

I have completed the installation of statsd as per the tute, but I cannot get the service to start! Whenever I run sudo service statsd start it will say it’s successful and give it a process number, but then I run a sudo service statsd status command it shows the status statsd stop/waiting. Anyone know what I might be able to do to track this issue down?

  • The first step to debugging this is to check the log file for error messages. The statsd log file should be found in /var/log/upstart/statsd.log

  • Thanks for that! I’m getting entries that read:

    Error: Cannot find module ’./servers/udp’
    at Function.Module.resolveFilename (module.js:338:15)
    at Function.Module.load (module.js:280:25)
    at Module.require (module.js:364:17)
    at require (module.js:380:17)
    at startServer (/usr/share/statsd/stats.js:54:19)
    at /usr/share/statsd/stats.js:190:20
    at null.<anonymous> (/usr/share/statsd/lib/config.js:40:5)
    at EventEmitter.emit (events.js:95:17)
    at /usr/share/statsd/lib/config.js:20:12
    at fs.js:268:14

    I’m having a hard time deciphering this, are you perhaps able to point me in the right direction?

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Submit an Answer
2 answers

Issue was resolved by @xellessprl

It seems that the command

sudo dpkg -i statsd*.deb

does not copy the “servers” folder in our system installation. I do not know if this is the best way to do things in nodejs but the following command solved the problem for me:

just after
sudo dpkg -i statsd*.deb


sudo cp -r ~/build/statsd/servers /usr/share/statsd