Symbolic link not allowed or link target not accessible

September 5, 2015 8.8k views
Apache

I am running virtualmin and have magento installed on my domain under ww.mydomain.com/store

I have set Magento up to have a second store which is under a subdomain and pointed to www.mydomain2.com

I have created a Symbolic link as per most tutorials for Magento to create a second store on a subdomain but I am getting the error

AH00037: Symbolic link not allowed or link target not accessible:

Unsure why or how to fix. User for all directories are the same and so are the file permissions

3 Answers

You need to give some more details. Wich webserver are you using? What would you like to link to what? Check the permissions of the items; ls -la

Beside the permissions, please check the vhost configuration to see if “Options FollowSymLinks” has been enabled (or not :-) ).

  • Beside the permissions, please check the vhost configuration to see if "Options FollowSymLinks" has been enabled (or not :-) ).
    

    This “Options FollowSymLinks” is only declared like that in apache, thats why I was wondering what webserver he was using. But indeed you need to check that when you are using apache.

    @SquareNet You need to give some more details, what webserver are you running? What would you like to link and check its permissions. The vhost of apache is default in /etc/apache/sites-available and its nginx is in /etc/nginx/sites-availabe.

I am using Ubuntu 14.04 x64 with VirtualMin installed on it.

Where is the vhost config at?

Have another answer? Share your knowledge.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!