The e-mailed root password is wrong?

I just started my first Droplet, and can’t get access to it. I was e-mailed a root password. I tried:

  • Using this password to login using my own SSH client.
  • Using this password to login on the console on the website.
  • Resetting the password and using the new one in both of the above cases. Nothing has worked. Both passwords failed to log me in, with access denied. The only thing I can think here is you’re sending the wrong passwords. Could someone look into this? I’m going to try the SSH key instead now, but this is rather annoying.

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

I’ve never had a problem with the passwords email, but make sure you connect to the IP address indicated in the email. If you create 2 or more droplets at the same time it does not mean that the emails will arrive in your mailbox in the correct order.

So always use the IP from the email. Also that password is temporary. You will be prompted for it twice as the server wants you to change it after logging in.

I use the terminal MobaXterm and it lets me copy/paste text. That makes it easy to use hashed passwords via KeePass.

RSA keys are better anyway and you should be using that if possible.

Please note that the passwords sent will be case sensitive. If you continue to have difficulty I strongly recommend opening a ticket with our support team either from the control panel or by emailing support@ and they will be able to review your droplet’s state and identify any issues.