Unable to connect to DO managed MySQL database - Error 61

I have connected to a DO managed MySQL database for months. Starting on 8/1/2023 the connection stopped working.

I used this DO tutorial to create the connection:

I have confirmed that:

  • I am using the CA certificate with the setting to “require and verify CA”
  • I have not reached a connection thread limit (5 out of 150 in use)
  • My IP address is white listed
  • The firewall on my Mac is turned off and I am not using a VPN

I have tried connecting using MySQL Workbench, PyCharm, and mysql CLI.

Is anyone else experiencing this issue? Anyone have any ideas on troubleshooting?

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Follow up on my original question:

I tested the connection on a different network and was able to connect to the database indicating that this may be an issue with the network I was on.

HOWEVER…I had the IP of my home network (the one that wasn’t working) white listed on Digital Ocean and verified that there are no firewalls on the network or my computer.

I tried connecting yesterday and could not. I tried connecting this morning and it worked! Same IP address, same computer and network settings. I didn’t change anything. Seems like this could have been a Digital Ocean bug or a bug with the WIFI router software (Eero).

Bobby Iliev
Site Moderator
Site Moderator badge
August 4, 2023

Hi there,

I’ve just checked the DigitalOcean status page and there have been no reported incidents that might have caused the problem for the past few days.

Error 61 usually signifies that the connection was actively refused, which may occur if your home IP address has changed and you would have to add your new IP address to the trusted sources of your database cluster.

You can follow the steps on how to do that here:

If this does not help there are a few other things that I could suggest:

  1. Test the network connection. Try using telnet or nc (netcat) to test the connection to your database host and port. This can help you identify if the problem lies with the network connection itself. For example, you can use the command telnet your-db-host 3306 (replace ‘your-db-host’ and ‘3306’ with your actual DB host and port).
  2. Try connecting from a different network. Sometimes, certain networks (like corporate or school networks) may block certain types of traffic. Trying from a different network (like a home network) might help identify if this is the issue.
  3. Verify that your database is running. You can check this from your DigitalOcean control panel. If there are any problems like for example the server has run out of disk space, you can try upgrading to a larger instance or also contacting the DigitalOcean support team.

Hope that this helps!



Try DigitalOcean for free

Click below to sign up and get $200 of credit to try our products over 60 days!

Sign up

Featured on Community

Get our biweekly newsletter

Sign up for Infrastructure as a Newsletter.

Hollie's Hub for Good

Working on improving health and education, reducing inequality, and spurring economic growth? We'd like to help.

Become a contributor

Get paid to write technical tutorials and select a tech-focused charity to receive a matching donation.

Welcome to the developer cloud

DigitalOcean makes it simple to launch in the cloud and scale up as you grow — whether you're running one virtual machine or ten thousand.

Learn more
DigitalOcean Cloud Control Panel