Unable to receive e-mail: "mail exchanger not found"

August 13, 2014 1.5k views

I am able to send e-mail from my mailboxes but am unable to receive any e-mails.

I get this mail delivery system error from gmail when I try to send e-mail to my mailboxes: "mail exchanger not found".

It seems the A record doesn't exist for mx record (but I DID add it). I ran it in the mxtoolbox this is result for my mx:

10 mail.-thedomain-.com {No A Record}.

I also keep getting this in exim logs: "dovecotplain authenticator failed for (uezzcmgvnx) [41.21.178.38]: 535 Incorrect authentication data (setid=webmaster@urnews24.com)", this is not my machine nor my ip in the log, seems weird

My domain name registar settings has main domain A record set to my VPS IP and mail.mydomain.com set as MX server (where "mydomain" is my actual domain).

The records are left as default in my control panel (after adding the domain and a mailbox), since they seem properly set up.
The A record for my MX (mail.mydomain.com pointing to my machine IP) does exist in my control panel...

To my knowledge everything should be working after I added the domain and created a mailbox for it (and setting up the dns/ms in the domain provider settings).

Not sure what am I missing.

The only way I managed to get it to work is to create a subdomain "mail.mydomain.com" in my domain provider panel and put A record on it to the machines IP, which doesn't seem right at all...

How do I get this A record to work with my MX?

Thank you for your help in advance.

1 Answer

It seems the A record doesn't exist for mx record (but I DID add it).

How long did you wait? Unfortunately, DNS can sometimes take quite a while to propagate.

I also keep getting this in exim logs: "dovecotplain authenticator failed for (uezzcmgvnx) [41.21.178.38]: 535 Incorrect authentication data (setid=webmaster@urnews24.com)", this is not my machine nor my ip in the log, seems weird

This is most likely someone attempting to access your SMTP port. This is way setting up authentication is important.

Have another answer? Share your knowledge.